XBRLizer main window

From XBRLWiki
Jump to: navigation, search

Screen capture

File:XBRLizerMain.png

This is XBRLizer main window

Visit the Symbols explained page for more information about the icons you have in front of you.

The main window contains the following sections:

Menu

The menu is divided in 3 sub sections

The File menu

  • Open... Open files, Taxonomies, XBRL Reports. See Compose DTS
  • Change DTS... This is active when an XBRL report is loaded
  • Create XBRL Report... This is active when a taxonomy is loaded
  • Create XBRL Report automatically... Creates an XBRL report from an XBRL Report Template. See the Process of creating an XBRL report from a template
  • Adds XBRL Facts to report... Merges the content of two XBRL Reports
  • Save XBRL Report... Saves the XBRL Report to disk
  • Print... Print out the current view
  • Export (Excel)... Export to Excel the current view
  • Save AS template for mapping... Creates an XBRL Template from the currently opened XBRL Report
  • Close. Closes currently opened taxonomy or XBRL report.

The Options menu

  • Enable experimental features
  • Languages...
  • Labels...
  • Log
  • Internet Proxy...
  • Catalog and URI Mapping...
  • Validation mode
  • Validation options...
  • GUI options...
  • Storage options...
  • Set beginning of year date...
  • Default monetary unit...
  • Validate now

The Help menu

  • About...
  • License...

Left pane: Data dictionary

Right pane: Upper section: Data tabs

Right pane: bottom section: Log and Validation windows

What do you want to do?

This section contains small walkthroughs around common tasks. Please, send us your feddback and or comments.

Open an instance document or taxonomy file

Use the File Open menu option. The DTSContainer window will allow you to specify a local file, a file on the Internet, a file on the Internet using the local Taxonomy Catalog, a file already stored into the XBRL Database etc.

Create a new XBRL report from scratch

  1. Use the File Open menu option. Select the taxonomy and or taxonomy files the new XBRL report will refer to.
  2. Use the File Create XBRL Report menu option. A dialog asking for default information will pop-up.
  3. The active tab pane will change to the Report pane.
  4. Select the proper presentation view in order to organize the left hand side of the window.
  5. Click on the columns window in order to create additional columns for entering data for another periods or dates.

Save the current XBRL report to a file

  1. Use the File Save XBRL Report menu option.
  2. Assign a proper file name
  3. Documents are validated before they are stored on disk. Only XBRL Valid documents can be stored. Calculation inconsistencies or any other inconsistency are not considered XBRL Errors. The validation process will tell you all validation errors and inconsistencies found.


This page is under construction. The link to this page only exist on release 2.7 of Reporting Standard S.L. tools.

Thanks for testing our tools.